re = /^(?![\s\S]*<othermeta content="V7" name="version"\/>)[\s\S]*<othermeta content="V6" name="version"\/>\K/
str = '<othermeta content="V5.1" name="version"/>
<othermeta content="V5.2" name="version"/>
<othermeta content="V6" name="version"/>
'
subst = '\\n<othermeta content="V7" name="version"/>'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result