const regex = /^(?![\s\S]*<othermeta content="V7" name="version"\/>)[\s\S]*<othermeta content="V6" name="version"\/>\K/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?![\\s\\S]*<othermeta content="V7" name="version"\\\/>)[\\s\\S]*<othermeta content="V6" name="version"\\\/>\\K', 'g')
const str = `<othermeta content="V5.1" name="version"/>
<othermeta content="V5.2" name="version"/>
<othermeta content="V6" name="version"/>
`;
const subst = `\n<othermeta content="V7" name="version"/>`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);