# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(?![\s\S]*<othermeta content=\"V7\" name=\"version\"\/>)[\s\S]*<othermeta content=\"V6\" name=\"version\"\/>\K"
test_str = ("<othermeta content=\"V5.1\" name=\"version\"/>\n"
"<othermeta content=\"V5.2\" name=\"version\"/>\n"
"<othermeta content=\"V6\" name=\"version\"/>\n")
subst = "\\n<othermeta content=\"V7\" name=\"version\"/>"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.