#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?!(?:\._|\.).*).*(?<!\(Disc [2-9]\))\..*(?<!bin)$"
Local $sString = "Castlevania Symphony of the Night (USA).chd" & @CRLF & _
"Chrono Cross (USA) (Disc 1).iso" & @CRLF & _
"Chrono Cross (USA) (Disc 2).iso" & @CRLF & _
"Crash Bandicoot (USA).cue" & @CRLF & _
"Crash Bandicoot (USA) (1).bin" & @CRLF & _
"Crash Bandicoot (USA) (2).bin" & @CRLF & _
"Final Fantasy VII (USA) (Disc 1).chd" & @CRLF & _
"Final Fantasy VII (USA) (Disc 2).chd" & @CRLF & _
"Final Fantasy VII (USA) (Disc 3).chd" & @CRLF & _
"Metal Gear Solid (USA) (Disc 1).cue" & @CRLF & _
"Metal Gear Solid (USA) (Disc 1) (1).bin" & @CRLF & _
"Metal Gear Solid (USA) (Disc 1) (2).bin" & @CRLF & _
"Metal Gear Solid (USA) (Disc 1) (3).bin" & @CRLF & _
"Metal Gear Solid (USA) (Disc 2).cue" & @CRLF & _
"Metal Gear Solid (USA) (Disc 2) (1).bin" & @CRLF & _
"Metal Gear Solid (USA) (Disc 2) (2).bin" & @CRLF & _
"Metal Gear Solid (USA) (Disc 2) (3).bin"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")