import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?!(?:\\._|\\.).*).*(?<!\\(Disc [2-9]\\))\\..*(?<!bin)$";
final String string = "Castlevania Symphony of the Night (USA).chd\n"
+ "Chrono Cross (USA) (Disc 1).iso\n"
+ "Chrono Cross (USA) (Disc 2).iso\n"
+ "Crash Bandicoot (USA).cue\n"
+ "Crash Bandicoot (USA) (1).bin\n"
+ "Crash Bandicoot (USA) (2).bin\n"
+ "Final Fantasy VII (USA) (Disc 1).chd\n"
+ "Final Fantasy VII (USA) (Disc 2).chd\n"
+ "Final Fantasy VII (USA) (Disc 3).chd\n"
+ "Metal Gear Solid (USA) (Disc 1).cue\n"
+ "Metal Gear Solid (USA) (Disc 1) (1).bin\n"
+ "Metal Gear Solid (USA) (Disc 1) (2).bin\n"
+ "Metal Gear Solid (USA) (Disc 1) (3).bin\n"
+ "Metal Gear Solid (USA) (Disc 2).cue\n"
+ "Metal Gear Solid (USA) (Disc 2) (1).bin\n"
+ "Metal Gear Solid (USA) (Disc 2) (2).bin\n"
+ "Metal Gear Solid (USA) (Disc 2) (3).bin";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}