import Foundation
let pattern = #"^(?!(?:\._|\.).*).*(?<!\(Disc [2-9]\))\..*(?<!bin)$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Castlevania Symphony of the Night (USA).chd
Chrono Cross (USA) (Disc 1).iso
Chrono Cross (USA) (Disc 2).iso
Crash Bandicoot (USA).cue
Crash Bandicoot (USA) (1).bin
Crash Bandicoot (USA) (2).bin
Final Fantasy VII (USA) (Disc 1).chd
Final Fantasy VII (USA) (Disc 2).chd
Final Fantasy VII (USA) (Disc 3).chd
Metal Gear Solid (USA) (Disc 1).cue
Metal Gear Solid (USA) (Disc 1) (1).bin
Metal Gear Solid (USA) (Disc 1) (2).bin
Metal Gear Solid (USA) (Disc 1) (3).bin
Metal Gear Solid (USA) (Disc 2).cue
Metal Gear Solid (USA) (Disc 2) (1).bin
Metal Gear Solid (USA) (Disc 2) (2).bin
Metal Gear Solid (USA) (Disc 2) (3).bin
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)