re = /^(?!(?:\._|\.).*).*(?<!\(Disc [2-9]\))\..*(?<!bin)$/m
str = 'Castlevania Symphony of the Night (USA).chd
Chrono Cross (USA) (Disc 1).iso
Chrono Cross (USA) (Disc 2).iso
Crash Bandicoot (USA).cue
Crash Bandicoot (USA) (1).bin
Crash Bandicoot (USA) (2).bin
Final Fantasy VII (USA) (Disc 1).chd
Final Fantasy VII (USA) (Disc 2).chd
Final Fantasy VII (USA) (Disc 3).chd
Metal Gear Solid (USA) (Disc 1).cue
Metal Gear Solid (USA) (Disc 1) (1).bin
Metal Gear Solid (USA) (Disc 1) (2).bin
Metal Gear Solid (USA) (Disc 1) (3).bin
Metal Gear Solid (USA) (Disc 2).cue
Metal Gear Solid (USA) (Disc 2) (1).bin
Metal Gear Solid (USA) (Disc 2) (2).bin
Metal Gear Solid (USA) (Disc 2) (3).bin'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end