use strict;
my $str = 'Castlevania Symphony of the Night (USA).chd
Chrono Cross (USA) (Disc 1).iso
Chrono Cross (USA) (Disc 2).iso
Crash Bandicoot (USA).cue
Crash Bandicoot (USA) (1).bin
Crash Bandicoot (USA) (2).bin
Final Fantasy VII (USA) (Disc 1).chd
Final Fantasy VII (USA) (Disc 2).chd
Final Fantasy VII (USA) (Disc 3).chd
Metal Gear Solid (USA) (Disc 1).cue
Metal Gear Solid (USA) (Disc 1) (1).bin
Metal Gear Solid (USA) (Disc 1) (2).bin
Metal Gear Solid (USA) (Disc 1) (3).bin
Metal Gear Solid (USA) (Disc 2).cue
Metal Gear Solid (USA) (Disc 2) (1).bin
Metal Gear Solid (USA) (Disc 2) (2).bin
Metal Gear Solid (USA) (Disc 2) (3).bin';
my $regex = qr/^(?!(?:\._|\.).*).*(?<!\(Disc [2-9]\))\..*(?<!bin)$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}