import re
regex = re.compile(r"^(?!(?:\._|\.).*).*(?<!\(Disc [2-9]\))\..*(?<!bin)$", flags=re.MULTILINE)
test_str = ("Castlevania Symphony of the Night (USA).chd\n"
"Chrono Cross (USA) (Disc 1).iso\n"
"Chrono Cross (USA) (Disc 2).iso\n"
"Crash Bandicoot (USA).cue\n"
"Crash Bandicoot (USA) (1).bin\n"
"Crash Bandicoot (USA) (2).bin\n"
"Final Fantasy VII (USA) (Disc 1).chd\n"
"Final Fantasy VII (USA) (Disc 2).chd\n"
"Final Fantasy VII (USA) (Disc 3).chd\n"
"Metal Gear Solid (USA) (Disc 1).cue\n"
"Metal Gear Solid (USA) (Disc 1) (1).bin\n"
"Metal Gear Solid (USA) (Disc 1) (2).bin\n"
"Metal Gear Solid (USA) (Disc 1) (3).bin\n"
"Metal Gear Solid (USA) (Disc 2).cue\n"
"Metal Gear Solid (USA) (Disc 2) (1).bin\n"
"Metal Gear Solid (USA) (Disc 2) (2).bin\n"
"Metal Gear Solid (USA) (Disc 2) (3).bin")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")