const regex = new RegExp('^(?!(?:\\._|\\.).*).*(?<!\\(Disc [2-9]\\))\\..*(?<!bin)$', 'gm')
const str = `Castlevania Symphony of the Night (USA).chd
Chrono Cross (USA) (Disc 1).iso
Chrono Cross (USA) (Disc 2).iso
Crash Bandicoot (USA).cue
Crash Bandicoot (USA) (1).bin
Crash Bandicoot (USA) (2).bin
Final Fantasy VII (USA) (Disc 1).chd
Final Fantasy VII (USA) (Disc 2).chd
Final Fantasy VII (USA) (Disc 3).chd
Metal Gear Solid (USA) (Disc 1).cue
Metal Gear Solid (USA) (Disc 1) (1).bin
Metal Gear Solid (USA) (Disc 1) (2).bin
Metal Gear Solid (USA) (Disc 1) (3).bin
Metal Gear Solid (USA) (Disc 2).cue
Metal Gear Solid (USA) (Disc 2) (1).bin
Metal Gear Solid (USA) (Disc 2) (2).bin
Metal Gear Solid (USA) (Disc 2) (3).bin`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}