using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?!(?:\._|\.).*).*(?<!\(Disc [2-9]\))\..*(?<!bin)$";
string input = @"Castlevania Symphony of the Night (USA).chd
Chrono Cross (USA) (Disc 1).iso
Chrono Cross (USA) (Disc 2).iso
Crash Bandicoot (USA).cue
Crash Bandicoot (USA) (1).bin
Crash Bandicoot (USA) (2).bin
Final Fantasy VII (USA) (Disc 1).chd
Final Fantasy VII (USA) (Disc 2).chd
Final Fantasy VII (USA) (Disc 3).chd
Metal Gear Solid (USA) (Disc 1).cue
Metal Gear Solid (USA) (Disc 1) (1).bin
Metal Gear Solid (USA) (Disc 1) (2).bin
Metal Gear Solid (USA) (Disc 1) (3).bin
Metal Gear Solid (USA) (Disc 2).cue
Metal Gear Solid (USA) (Disc 2) (1).bin
Metal Gear Solid (USA) (Disc 2) (2).bin
Metal Gear Solid (USA) (Disc 2) (3).bin";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}