# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?:<(strong|em|a|div|span)[^>]*?>(?P<txt>.*?)<\\/\1>|<(hr|img)[^>]*?\\/>)/\2/g;t' <<< "<p><strong style=\"background:red\">hola mundo</strong> este es el <hrsss/> dia de <img src=\"\" /> <em>italica</em>.<p>"