using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:<(strong|em|a|div|span)[^>]*?>(?P<txt>.*?)<\/\1>|<(hr|img)[^>]*?\/>)";
string substitution = @"\2";
string input = @"<p><strong style=""background:red"">hola mundo</strong> este es el <hrsss/> dia de <img src="" /> <em>italica</em>.<p>";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}