$re = '/(?:<(strong|em|a|div|span)[^>]*?>(?P<txt>.*?)<\/\1>|<(hr|img)[^>]*?\/>)/';
$str = '<p><strong style="background:red">hola mundo</strong> este es el <hrsss/> dia de <img src="" /> <em>italica</em>.<p>';
$subst = "\2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;