import re
regex = re.compile(r"(?:<(strong|em|a|div|span)[^>]*?>(?P<txt>.*?)<\/\1>|<(hr|img)[^>]*?\/>)")
test_str = "<p><strong style=\"background:red\">hola mundo</strong> este es el <hrsss/> dia de <img src=\"\" /> <em>italica</em>.<p>"
subst = "\\2"
result = regex.sub(subst, test_str)
if result:
print(result)