import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:<(strong|em|a|div|span)[^>]*?>(?P<txt>.*?)<\\/\\1>|<(hr|img)[^>]*?\\/>)";
final String string = "<p><strong style=\"background:red\">hola mundo</strong> este es el <hrsss/> dia de <img src=\"\" /> <em>italica</em>.<p>";
final String subst = "\\2";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}