const regex = new RegExp('(?:<(strong|em|a|div|span)[^>]*?>(?P<txt>.*?)<\\/\\1>|<(hr|img)[^>]*?\\/>)', 'g')
const str = `<p><strong style="background:red">hola mundo</strong> este es el <hrsss/> dia de <img src="" /> <em>italica</em>.<p>`;
const subst = `\2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);