import Foundation
let pattern = #"(?:<(strong|em|a|div|span)[^>]*?>(?P<txt>.*?)<\/\1>|<(hr|img)[^>]*?\/>)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"<p><strong style="background:red">hola mundo</strong> este es el <hrsss/> dia de <img src="" /> <em>italica</em>.<p>"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\2"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)