using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(""[^""]*)ABC([^.][^""]*""|"")";
string substitution = @"\1DEF\2";
string input = @"BLABLUB SHSJSKSKDKDNDNDK hD ABC mmmjkk ""hshs ABC.TTTTT"" dndjmsmdmdmdmdm ""blablub ABC blablub"" khhg ""zzggj ABC""";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase | RegexOptions.Singleline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}