import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\"[^\"]*)ABC([^.][^\"]*\"|\")";
final String string = "BLABLUB SHSJSKSKDKDNDNDK hD ABC mmmjkk \"hshs ABC.TTTTT\" dndjmsmdmdmdmdm \"blablub ABC blablub\" khhg \"zzggj ABC\"";
final String subst = "\\1DEF\\2";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE | Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}