# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(\"[^\"]*)ABC([^.][^\"]*\"|\")"
test_str = "BLABLUB SHSJSKSKDKDNDNDK hD ABC mmmjkk \"hshs ABC.TTTTT\" dndjmsmdmdmdmdm \"blablub ABC blablub\" khhg \"zzggj ABC\""
subst = "\\1DEF\\2"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE | re.IGNORECASE | re.DOTALL)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.