re = /("[^"]*)ABC([^.][^"]*"|")/mi
str = 'BLABLUB SHSJSKSKDKDNDNDK hD ABC mmmjkk "hshs ABC.TTTTT" dndjmsmdmdmdmdm "blablub ABC blablub" khhg "zzggj ABC"'
subst = '\\1DEF\\2'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result