// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?mis)("[^"]*)ABC([^.][^"]*"|")"#).unwrap();
let string = "BLABLUB SHSJSKSKDKDNDNDK hD ABC mmmjkk \"hshs ABC.TTTTT\" dndjmsmdmdmdmdm \"blablub ABC blablub\" khhg \"zzggj ABC\"";
let substitution = "\\1DEF\\2";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}