import Foundation
let pattern = #"("[^"]*)ABC([^.][^"]*"|")"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .caseInsensitive, .dotMatchesLineSeparators])
let testString = #"BLABLUB SHSJSKSKDKDNDNDK hD ABC mmmjkk "hshs ABC.TTTTT" dndjmsmdmdmdmdm "blablub ABC blablub" khhg "zzggj ABC""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\1DEF\2"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)