const regex = /("[^"]*)ABC([^.][^"]*"|")/gmis;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('("[^"]*)ABC([^.][^"]*"|")', 'gmis')
const str = `BLABLUB SHSJSKSKDKDNDNDK hD ABC mmmjkk "hshs ABC.TTTTT" dndjmsmdmdmdmdm "blablub ABC blablub" khhg "zzggj ABC"`;
const subst = `\1DEF\2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);