package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mis)("[^"]*)ABC([^.][^"]*"|")`)
var str = `BLABLUB SHSJSKSKDKDNDNDK hD ABC mmmjkk "hshs ABC.TTTTT" dndjmsmdmdmdmdm "blablub ABC blablub" khhg "zzggj ABC"`
var substitution = "\1DEF\2"
fmt.Println(re.ReplaceAllString(str, substitution))
}