$re = '/("[^"]*)ABC([^.][^"]*"|")/mis';
$str = 'BLABLUB SHSJSKSKDKDNDNDK hD ABC mmmjkk "hshs ABC.TTTTT" dndjmsmdmdmdmdm "blablub ABC blablub" khhg "zzggj ABC"';
$subst = "\1DEF\2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;