# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\b-(\s+(?:and|to|or)(?:\s+\w+)*\s+\w+(-\w[\w-]*))/\2\1/gm;t' <<< "But seeing them playing to seven- and eight-year-olds is beautiful
The country was in the uproar of pre- and then post-independence civil war but the mood here is most often joyous"