import re
regex = re.compile(r"\b-(\s+(?:and|to|or)(?:\s+\w+)*\s+\w+(-\w[\w-]*))", flags=re.MULTILINE)
test_str = ("But seeing them playing to seven- and eight-year-olds is beautiful\n"
"The country was in the uproar of pre- and then post-independence civil war but the mood here is most often joyous")
subst = "\\2\\1"
result = regex.sub(subst, test_str)
if result:
print(result)