import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b-(\\s+(?:and|to|or)(?:\\s+\\w+)*\\s+\\w+(-\\w[\\w-]*))";
final String string = "But seeing them playing to seven- and eight-year-olds is beautiful\n"
+ "The country was in the uproar of pre- and then post-independence civil war but the mood here is most often joyous";
final String subst = "\\2\\1";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}