$re = '/\b-(\s+(?:and|to|or)(?:\s+\w+)*\s+\w+(-\w[\w-]*))/m';
$str = 'But seeing them playing to seven- and eight-year-olds is beautiful
The country was in the uproar of pre- and then post-independence civil war but the mood here is most often joyous';
$subst = "\2\1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;