using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b-(\s+(?:and|to|or)(?:\s+\w+)*\s+\w+(-\w[\w-]*))";
string substitution = @"\2\1";
string input = @"But seeing them playing to seven- and eight-year-olds is beautiful
The country was in the uproar of pre- and then post-independence civil war but the mood here is most often joyous";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}