use strict;
my $str = 'But seeing them playing to seven- and eight-year-olds is beautiful
The country was in the uproar of pre- and then post-independence civil war but the mood here is most often joyous';
my $regex = qr/\b-(\s+(?:and|to|or)(?:\s+\w+)*\s+\w+(-\w[\w-]*))/mp;
my $subst = '\\2\\1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";