#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(bra){3}"
Local $sString = "# Quantifier:{number} 篇" & @CRLF & _
"" & @CRLF & _
"#下方為測試文字區塊" & @CRLF & _
"b" & @CRLF & _
"br" & @CRLF & _
"bra" & @CRLF & _
"brabra" & @CRLF & _
"brabrabra" & @CRLF & _
"brabrabra brabrabrabarbarbabarbarbab" & @CRLF & _
"" & @CRLF & _
"#解釋:藍色部分就是透過規則/(bra){3}/所配對成功的文字,當 (bra)這組配對出現三次食就算配對成功。" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")