import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(bra){3}";
final String string = "# Quantifier:{number} 篇\n\n"
+ "#下方為測試文字區塊\n"
+ "b\n"
+ "br\n"
+ "bra\n"
+ "brabra\n"
+ "brabrabra\n"
+ "brabrabra brabrabrabarbarbabarbarbab\n\n"
+ "#解釋:藍色部分就是透過規則/(bra){3}/所配對成功的文字,當 (bra)這組配對出現三次食就算配對成功。\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}