# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(bra){3}"
test_str = ("# Quantifier:{number} 篇\n\n"
"#下方為測試文字區塊\n"
"b\n"
"br\n"
"bra\n"
"brabra\n"
"brabrabra\n"
"brabrabra brabrabrabarbarbabarbarbab\n\n"
"#解釋:藍色部分就是透過規則/(bra){3}/所配對成功的文字,當 (bra)這組配對出現三次食就算配對成功。\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.