using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(bra){3}";
string input = @"# Quantifier:{number} 篇
#下方為測試文字區塊
b
br
bra
brabra
brabrabra
brabrabra brabrabrabarbarbabarbarbab
#解釋:藍色部分就是透過規則/(bra){3}/所配對成功的文字,當 (bra)這組配對出現三次食就算配對成功。
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}