const regex = /(bra){3}/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(bra){3}', 'gm')
const str = `# Quantifier:{number} 篇
#下方為測試文字區塊
b
br
bra
brabra
brabrabra
brabrabra brabrabrabarbarbabarbarbab
#解釋:藍色部分就是透過規則/(bra){3}/所配對成功的文字,當 (bra)這組配對出現三次食就算配對成功。
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}