package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(bra){3}`)
var str = `# Quantifier:{number} 篇
#下方為測試文字區塊
b
br
bra
brabra
brabrabra
brabrabra brabrabrabarbarbabarbarbab
#解釋:藍色部分就是透過規則/(bra){3}/所配對成功的文字,當 (bra)這組配對出現三次食就算配對成功。
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}