use strict;
my $str = '# Quantifier:{number} 篇
#下方為測試文字區塊
b
br
bra
brabra
brabrabra
brabrabra brabrabrabarbarbabarbarbab
#解釋:藍色部分就是透過規則/(bra){3}/所配對成功的文字,當 (bra)這組配對出現三次食就算配對成功。
';
my $regex = qr/(bra){3}/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}