# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\S*#(\[[^\]]+\]|\S+)/<a href="targetpage.php?val=$1">#$1<\/a>/gm;t' <<< "Some text #tag1 text #tag2 ..."