$re = '/\S*#(\[[^\]]+\]|\S+)/m';
$str = 'Some text #tag1 text #tag2 ...';
$subst = "<a href=\"targetpage.php?val=$1\">#$1</a>";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;