import Foundation
let pattern = ##"\S*#(\[[^\]]+\]|\S+)"##
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = ##"Some text #tag1 text #tag2 ..."##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = ##"<a href="targetpage.php?val=$1">#$1</a>"##
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)