#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)\S*#(\[[^\]]+\]|\S+)"
Local $sString = "Some text #tag1 text #tag2 ..."
Local $sSubst = "<a href="targetpage.php?val=$1">#$1</a>"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)