package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\S*#(\[[^\]]+\]|\S+)`)
var str = `Some text #tag1 text #tag2 ...`
var substitution = "<a href="targetpage.php?val=$1">#$1</a>"
fmt.Println(re.ReplaceAllString(str, substitution))
}