using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\S*#(\[[^\]]+\]|\S+)";
string substitution = @"<a href=""targetpage.php?val=$1"">#$1</a>";
string input = @"Some text #tag1 text #tag2 ...";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}