const regex = /\S*#(\[[^\]]+\]|\S+)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\S*#(\\[[^\\]]+\\]|\\S+)', 'gm')
const str = `Some text #tag1 text #tag2 ...`;
const subst = `<a href="targetpage.php?val=$1">#$1</a>`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);