// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\S*#(\[[^\]]+\]|\S+)").unwrap();
let string = "Some text #tag1 text #tag2 ...";
let substitution = "<a href=\"targetpage.php?val=$1\">#$1</a>";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}