#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "<a.+title="(.*Zennolab.*?)">"
Local $sString = "border="0" ></div><a href="http://domain.com/" title="Текст заголовка Zennolab">" & @CRLF & _
"border="0" ></div><a href="http://domain.com/" title="Текст Zennolab заголовка">" & @CRLF & _
"border="0" ></div><a href="http://domain.com/" title="Zennolab">" & @CRLF & _
"border="0" ></div><a href="http://domain.com/" title="Текст заголовка">"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")