import re
regex = re.compile(r"<a.+title=\"(.*Zennolab.*?)\">")
test_str = ("border=\"0\" ></div><a href=\"http://domain.com/\" title=\"Текст заголовка Zennolab\">\n"
"border=\"0\" ></div><a href=\"http://domain.com/\" title=\"Текст Zennolab заголовка\">\n"
"border=\"0\" ></div><a href=\"http://domain.com/\" title=\"Zennolab\">\n"
"border=\"0\" ></div><a href=\"http://domain.com/\" title=\"Текст заголовка\">")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")